Знакомство с разработкой мобильных приложений на платформе скачать

Знакомство с разработкой мобильных приложений на платформе "1С:Предприятие 8" (+CD). Издание 2

знакомство с разработкой мобильных приложений на платформе скачать

Знакомство с разработкой мобильных приложений на платформе 1С: Предприятие 8 - Хрусталева Е.Ю Скачать Добавить в свою библиотеку. Качество: хорошее. Язык: русский. Скачать Знакомство с разработкой мобильных приложений на платформе 1С: Предприятие 8. 1C-Рарус за 5 минут|; Скачать прайс-лист для Москвы |; Другие прайс-листы|. Скачать . Технологическая платформа; Книга «Знакомство с разработкой мобильных приложений на платформе 1С:Предприятие 8» (+CD). Изд. 2.

В статье будет рассматриваться пример разработки приложения для Android. В связи с этим придется загрузить: Первый компонент содержит все необходимое для сборки приложения и эмулятор для тестирования, а WEB-сервер пригодится для быстрой загрузки приложения на мобильную ОС. Она содержит конфигурацию для упрощения процесса сборки созданного мобильного приложения, а также мобильную платформу разработчика.

Ее необходимо установить на мобильном устройстве или эмуляторе. Эта тема выходит за рамки статьи, поэтому узнать подробности о работе с этими инструментами и сборкой приложения вы можете в соответствующем разделе моего блога.

Перед вами появится окно с выбором доступных пакетов для установки. Для тестирования, рассматриваемого в рамках статьи примера, потребуется выбрать и установить: Последним шагом будет создание новой информационной базы. Дерево конфигурации объектов, из которых будет состоять будущее приложение отобразится в левой части окна.

В правой части окна конфигуратора откроется редактор свойств. Обратите внимание, выполнив последнее действие, некоторые узлы дерева конфигурации станут неактивными. К сожалению, воспользоваться всеми объектами метаданных на мобильной платформе не получится.

Пример создания мобильного приложения в 1С с нуля | Мой киборг-сеть программных разработок

Для решения нашей задачи, в дереве конфигурации нам потребуется создать несколько объектов метаданных: Ими будем определять состояние созданных задач. Элементы справочника определяют ответственных лиц, то есть исполнителей. Здесь будем хранить все задачи. Описание строка, ; Ответственный СправочникСсылка. Регистр будет хранить историю изменения состояния задачи. СтатусыЗадач ; Этих объектов нам вполне хватит для решения задачи и обкатки возможностей мобильной платформы.

Знакомство с разработкой мобильных приложений на платформе 1С: Предприятие 8

Я на этом заострять внимание не стану, так как статья не резиновая, а просто приведу скриншот моего варианта оформления. Вы можете сделать что-то подобное или положиться на платформу, которая при необходимости сгенерирует необходимые формы автоматически.

Для этого откроем модуль менеджера правый клик по регистру и опишем в нем две процедуры см. Первый листинг реализует добавление новой записи в регистр посредством менеджера записи. Этот реквизит автоматически создается для всех периодических регистров сведений и необходим для идентификации записи на временной оси.

Второй листинг по сложности немногим отличается от первого. В нем описан запрос к регистру сведений для получения не закрытых задач. Результат запроса выгружается в таблицу значений. Записать ; КонецПроцедуры Листинг 2.

знакомство с разработкой мобильных приложений на платформе скачать

Выгрузить ; КонецФункции С получением данных из регистра сведений и их записью разобрались, теперь научим наш справочник работать с регистром. Можно обойтись и без него, но мне сразу хочется акцентировать внимание на возможность разбивки кода по модулям. Многие 1С-разработчики до сих пор пренебрегают этой рекомендацией и всю логику описывают в одном месте, тем самым затрудняя последующее сопровождения кода.

Выбрать ; Если Результат. Следующий Тогда Если Результат. ДобавитьЗадачу Ссылка ; КонецЕсли; КонецПроцедуры Перед тем как создать новую запись выполняется проверка на наличие уже имеющихся записей по задаче. Если запись уже существует, то надо сравнить статусы задач.

знакомство с разработкой мобильных приложений на платформе скачать

Если статус из регистра не отличается от статуса записываемого элемента, в создании дополнительной записи необходимость отсутствует. В нем напишем вызов процедуры, описанной в третьем листинге: Ссылка ; Работаем над интерфейсом Основной функционал приложения готов — пользователь может создавать задачи, и каждая новая задача формирует запись в периодическом регистре сведений.

Вынесем работу с задачами на передний план. Ведь логично сразу после запуска приложения отображать список не закрытых задач и возможность создать новую? Следующим шагом перетащим добавленный реквизит на форму.

У нас должен получиться интерфейс простейшей таблицы. Никакие размеры указывать не будем, оставим заботу о масштабировании интерфейса платформе.

Мы будем заполнять таблицу динамическими сведениями, поэтому смысла в редактировании со стороны пользователя.

знакомство с разработкой мобильных приложений на платформе скачать

Добавим в него одну строку кода: Для более выразительного оформления кнопок добавим изображения и изменим шрифт по умолчанию. Это позволит создавать задачи, минуя вход в сам справочник. По нажатию второй кнопки будем обновлять содержимое таблицы с задачами. Для этого потребуется создать дополнительную команду формы.

  • книга Знакомство с разработкой мобильных приложений на платформе 1С: Предприятие 8
  • Знакомство с разработкой мобильных приложений на платформе "1С:Предприятие 8" (Издание 2)
  • книга Знакомство с разработкой мобильных приложений на платформе 1С: Предприятие 8

Принцип прост — добавляем новую команду, описываем в ней код действия и затем связываем команду с интерфейсом, в нашем случае с кнопкой. Не стоит также забывать, что мы разрабатываем управляемое приложение, поэтому надо четко разграничивать клиентский и серверный код.

В коде это выглядит так: Технические ограничения, высокая стоимость не позволили продукту повторить колоссальный успех настольной платформы. Идея завоевать мобильный рынок корпоративных приложений с треском провалилась. Шаг вперед Проигрыш и убытки от неудачного проекта не поставили окончательную точку на развитии перспективного направления.

Результатом стал абсолютно новый инструмент, не имеющий ничего общего с предшественником и ориентированный на самые актуальные мобильные платформы — Android и iOS.

Мобильные приложения в стиле 1С Для полноценного знакомства с возможностями разработки под мобильные платформы попробуем разработать небольшую конфигурацию. Для воссоздания примера ее возможностей более чем достаточно. В статье будет рассматриваться пример разработки приложения для Android. Первый компонент содержит все необходимое для сборки приложения и эмулятор для тестирования, а веб-сервер пригодится для быстрой загрузки приложения на мобильную ОС см.

Она содержит конфигурацию для упрощения процесса сборки созданного мобильного приложения, а также мобильную платформу разработчика. Ее необходимо установить на мобильном устройстве или эмуляторе. Эта тема выходит за рамки статьи, поэтому узнать подробности о работе с этими инструментами и сборкой приложения вы можете в соответствующем разделе блога [2].